Issue with KYC sanctions checks
Incident Report for WealthKernel
Resolved
This incident has been resolved.
Posted Nov 12, 2021 - 13:24 GMT
Investigating
We are currently investigating an issue with KYC sanctions checks
Posted Nov 12, 2021 - 11:57 GMT
This incident affected: Production: KYC.