Production Direct Debits Outage

Incident Report for WealthKernel

Resolved

This incident has been resolved.
Posted May 29, 2025 - 13:37 BST

Identified

We have identified an issue with our third party Direct Debit provider that is blocking Mandates, Payment and Subscriptions from being created.
Posted May 29, 2025 - 12:27 BST
This incident affected: Production: API.